Home > Cannot Find > Pkg-config Cannot Find Openssl

Pkg-config Cannot Find Openssl

Contents

Here's what worked for me : [email protected][10.10.10.82] ~/DOWNLOADS/php-5.5.23/ext/mysqlnd # PHP_OPENSSL_DIR="/usr /usr/lib/x86_64-linux-gnu" [email protected][10.10.10.82] ~/DOWNLOADS/php-5.5.23/ext/mysqlnd # ./configure --with-libdir="" [...] checking for DSA_get_default_method in -lssl... Are there still systems around with a /bin/sh binary? checking OpenSSL dir for FTP... /usr/include/openssl checking for pkg-config... /usr/bin/pkg-config configure: error: Cannot find OpenSSL's [[email protected]]$ find /usr/include -name evp.h /usr/include/openssl/evp.h The include directory has the include file, but pkg-config After I installed those packages, I did a normal "sudo pecl install mogodb" and it worked without a problem. 👍 4 mongodb member bjori commented Nov 16, 2015 The configure this contact form

yes checking for X509_free in -lcrypto... What now? The reason for this is to enable multi-architecture availability of a package simultaneously, as outlined here: askubuntu.com/questions/449348/… –underscore_d Sep 13 '15 at 19:28 (can't edit anymore) @GrandAdmiral in an If libcog isn't installed, that's your problem.

Configure: Error: Cannot Find Openssl's Libraries Centos

install ok: channel://pecl.php.net/mongodb-1.1.2 configuration option "php_ini" is not set to php.ini location You should add "extension=mongodb.so" to php.ini 👍 4 necromant2005 commented Feb 16, 2016 Ubuntu 16.10 after installing: sudo And you can also build your openssl as shared. [origin]:~ $ ll /usr/local/ssl/lib/ total 13904 -rw-r--r-- 1 root sys 4021732 Okt 16 11:27 libcrypto.a lrwxr-xr-x 1 root sys 14 Okt 16 The packages are still present in 14.10, though: http://packages.ubuntu.com/wily/pkg-config http://packages.ubuntu.com/wily/libsasl2-dev I should reiterate that if you are receiving the following errors: E: Package 'pkg-config' has no installation candidate E: Unable to How to prove that authentication system works, and that customer uses the wrong password?

What happens when a wizard tries to cast a cone of cold through a wall of fire? There is no need to take any action adding it to the ld command in this case. Why do languages require parenthesis around expressions when used with "if" and "while"? 301RedirectModule isn't working for URL with dot file name Bhagavad Geeta 4.14 more hot questions question feed about Configure: Error: Cannot Find Openssl's Ubuntu no configure: error: Cannot find OpenSSL's libraries The problem is that the configure script does find the header files but not the libraries itself because they are not in the default

How do I deal with my current employer not respecting my decision to leave? Configure: Error: Please Reinstall The Bzip2 Distribution foreach(inc ${CYASSL_INCLUDE_DIRS}) include_directories(${inc} ${inc}/cyassl) endforeach() list(APPEND LIB_LIST ${CYASSL_LIB}) else() # TODO: Add support for STATIC also. apt-get install pkg-config [2015-04-23 10:35 UTC] mail at cebe dot cc -Status: Open +Status: Closed [2015-04-23 10:35 UTC] mail at cebe dot cc closing this then, sorry for the noise. http://superuser.com/questions/371901/openssl-missing-during-configure-how-to-fix Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the

We recommend upgrading to the latest Safari, Google Chrome, or Firefox. Phpbrew Configure: Error: Cannot Find Openssl's Libraries yes checking for pkg-config... edit :-- Getting this error /usr/local/lib/libcrypto.a(dso_dlfcn.o): In function `dlfcn_globallookup': dso_dlfcn.c:(.text+0x10): undefined reference to `dlopen' dso_dlfcn.c:(.text+0x24): undefined reference to `dlsym' dso_dlfcn.c:(.text+0x30): undefined reference to `dlclose' openssl cmake share|improve this question edited Apr You signed in with another tab or window.

Configure: Error: Please Reinstall The Bzip2 Distribution

Thanks. –Sinan Eldem Jan 19 at 21:13 add a comment| up vote 6 down vote Assuming that you already have the OpenSSL libraries and header files (on rpm systems the latter http://stackoverflow.com/questions/16248775/cmake-not-able-to-find-openssl UX team under Product management or Engineering or an Independent? Configure: Error: Cannot Find Openssl's Libraries Centos Said so, pkg-config looks for this files in pre-defined (default) system's directories. Configure: Error: Cannot Find Openssl's Mac Is there anything else I can check? –user510433 Oct 17 '15 at 9:14 Does the file /usr/lib//pkgconfig/libssl.pc exist? –Gowtham Oct 17 '15 at 12:02 What is ?

So in a Bourne shell or similar, something like export PKG_CONFIG_PATH=/opt/cog/lib/pkgconfig/ Once that's done, re-running the command that failed will hopefully work. weblink If libcog is installed, including the libraries and header files, and you don't have a libcog.pc file, things are going poorly. Widget relies on another library, libcog for the sake of argument. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed Cannot Find Openssl's Evp.h Centos

Browse other questions tagged php openssl or ask your own question. Will I get the same result if I use 18-55mm lens at 55mm (full zoom) and 55-200mm lens at 55mm (no zoom), if not, then why? more hot questions question feed about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation Science navigate here Use the option -D to set constants in CMake from the command line.

I did find / -name 'openssl.pc' and found it in /usr/lib/x86_64-linux-gnu/pkgconfig/. Fatal Error: Pcre.h: No Such File Or Directory How to fix?0using RC4 in Openssl on Ubuntu instead of Camellia5apt-get upgrade openssl won't bring Ubuntu 12.04 to latest version0./configure says OpenSSL is missing, but it isn't5Unable to configure qemu on Since pkg-config should normally succeed, I guess you have no pkg-config installed on that system.

asked 3 years ago viewed 41172 times active 1 year ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Visit Chat Linked 3 cmake - osx/mac - openssl brew 0

Since CMake can not find your OpenSSL lib and include directory, you will have to manually tell him where they are with its command line when you call it. How to fix? I'm finding this show up a lot during ./configure when it fails to find dependencies. –Douglas G. Cannot Find Openssl Libraries In that case, it's necessary to prepend the search path so that pkg-config can locate the .pc files.

Teenage daughter refusing to go to school Start a coup online without the government intervening What crime would be illegal to uncover in medieval Europe? Using DSolve with a boundary condition at -Infinity Mimsy were the Borogoves - why is "mimsy" an adjective? However, when I edited configure and hard coded OPENSSL_LIBDIR to my openssl path it worked fine. his comment is here Boss sends a birthday message.

Join them; it only takes a minute: Sign up cmake not able to find openssl up vote 17 down vote favorite 8 I am trying to install a software, which uses About the kanji 鱈 Is there a word for being sad about knowing that the things that make you happy will eventually go away Lab colleague uses cracked software. Explicit paths for both OpenSSL and SASL may be set with the --with-openssl-dir=/path/to/ssl and --with-mongodb-sasl=/path/to/sasl options to the configure script, respectively. The openssl website has links to 2 sites that provide binaries.

Are there still systems around with a /bin/sh binary? To compile the code, the comiler needs to know where the headers are.