Home > Cannot Find > Php Error Cannot Find Libmysqlclient Under /usr

Php Error Cannot Find Libmysqlclient Under /usr

Contents

Did you compile libmysql or install from repo? –beiller Sep 9 '14 at 15:44 Using Ubuntu, I installed libmysql from repo. –inimrepus Sep 9 '14 at 15:45 1 Lab colleague uses cracked software. The "--with-libdir=lib64" is what solved the problem, after downloading the devel RPM. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed this contact form

current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list. more hot questions question feed lang-php about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation I just removed the --with-lib-dir option. if the lib's in /foo/bar/baz/libmysql.so, you have to do --with-mysql=/foo/bar instead. –Marc B Sep 9 '14 at 15:44 I gave this a shot and no such luck. –inimrepus Sep you could try here

Cannot Find Mysql Header Files Under

Thanks. That was entirely my fault. current community blog chat Server Fault Meta Server Fault your communities Sign up or log in to customize your list. Why is the 'You talking to me' speech from the movie 'Taxi Driver' so famous?

here is the command I used and it works: sudo ./configure --prefix=/opt/php5.2 --with-config-file-path=/opt/php5.2 --with-mysql --with-libdir=/lib/x86_64-linux-gnu share|improve this answer answered Jun 21 '12 at 9:16 farzam 4402516 How did you Does it make a difference that the server is x32? –inimrepus Sep 9 '14 at 15:50 | show 5 more comments Your Answer draft saved draft discarded Sign up or while build PHP 5.2 from source on Ubuntu 12.4 Related 13CLSQL and MYSQL on OS X62Ruby gem mysql2 install failing1building mysql client library with ssl support10Cannot find libmysqlclient under /usr. Checking For Specified Location Of The Mysql Unix Socket... No trickykid View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by trickykid 02-03-2009, 01:43 AM #3 [email protected] LQ Newbie Registered: Feb 2009 Posts:

Last edited by neocontrol; 09-07-2007 at 11:22 AM. php mysql ubuntu libmysql share|improve this question asked Sep 9 '14 at 15:38 inimrepus 3427 as I recall, the mysql stuff is wonky, and you have to point configure Thanks. More hints How can an advanced (circa 7000 AD) spacefaring human civilization be prevented from entering its own solar system?

Are you new to LinuxQuestions.org? Note That The Mysql Client Library Is Not Bundled Anymore! Does Intel sell CPUs in ribbons? Registration is quick, simple and absolutely free. Build me a brick wall!

Cannot Find Libmysqlclient_r

no checking for MySQL support... https://www.howtoforge.com/how-to-use-multiple-php-versions-php-fpm-and-fastcgi-with-ispconfig-3-debian-wheezy-p2 I tried finding it and here is the result: `./usr/share/doc/libmysqlclient-dev ./usr/share/doc/libmysqlclient18 ./usr/lib/x86_64-linux-gnu/libmysqlclient.so ./usr/lib/x86_64-linux-gnu/libmysqlclient.a ./usr/lib/x86_64-linux-gnu/libmysqlclient_r.so.18 ./usr/lib/x86_64-linux-gnu/libmysqlclient_r.so.18.0.0 ./usr/lib/x86_64-linux-gnu/libmysqlclient_r.so ./usr/lib/x86_64-linux-gnu/libmysqlclient_r.a ./usr/lib/x86_64-linux-gnu/libmysqlclient.so.18.0.0 ./usr/lib/x86_64-linux-gnu/libmysqlclient.so.18 ... –farzam Jun 21 '12 at 8:29 @hakre I will Cannot Find Mysql Header Files Under What now? Php Cannot Find Libmysqlclient_r Anyhow the article needed to be updated so for pointing it out the first time we appreciate the note.

Does my 7 segment display need a bypass capacitor? weblink iforce2d View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by iforce2d 07-27-2012, 04:14 AM #9 justin69 LQ Newbie Registered: Jul 2012 Posts: How can an advanced (circa 7000 AD) spacefaring human civilization be prevented from entering its own solar system? add a comment| 3 Answers 3 active oldest votes up vote 2 down vote accepted you could try give different path for mysql, ie: --with-mysql=/usr/lib64 m share|improve this answer answered Sep Configure Error Cannot Find Mysql Header Files Under Usr Bin

while build PHP 5.2 from source on Ubuntu 12.4 Updated from your comment! Is there still a way to prevent Trump from becoming president? In Revelation 19:16, of which kings is Jesus king? http://amigasuperbit.com/cannot-find/php-configure-error-cannot-find-libmysqlclient-under.html Join them; it only takes a minute: Sign up Here's how it works: Anybody can ask a question Anybody can answer The best answers are voted up and rise to the

Note that the MySQL client library is not bundled anymore! Install Libmysqlclient I downloaded the lastest mysql rpms as well, and install those. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed

This second one is just annoying especially venting frustration for an article we took the time to write in our free time as an effort to help others resolve an issue.

Notices Welcome to LinuxQuestions.org, a friendly and active Linux Community. Alternating Fibonacci Is there a word for being sad about knowing that the things that make you happy will eventually go away What's the pun about? A guy scammed me, but he gave me a bank account number & routing number. Configure: Error: Cannot Find Openssl's Libraries [email protected] View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by [email protected] 11-17-2009, 05:52 AM #4 augustofagioli LQ Newbie Registered: Nov 2009 Posts:

noconfigure: error: Cannot find libmysqlclient under /usr.Note that the MySQL client library is not bundled anymore!Trying to compile on squeeze..

Tutorials How To Use Multiple PHP Versions (PHP-FPM & FastCGI) For Ubuntu Precise, I had to use "--with-libdir=/lib/x86_64-linux-gnu". How often should I replace windscreen wiper blades? http://amigasuperbit.com/cannot-find/phpfarm-configure-error-cannot-find-libmysqlclient-under-usr.html I think it's important that you take care that question and answer are of general use, e.g.

No, create an account now. thanks for pointing out. Thank you very much!! The server quit without updating PID file How to Configure NVFax on FreePBX Question Defense ©2016 $ sudo su - Search Main menu Skip to primary content Skip to secondary content

yes checking for specified location of the MySQL UNIX socket... more hot questions question feed default about us tour help blog chat data legal privacy policy work here advertising info mobile contact us feedback Technology Life / Arts Culture / Recreation grob115 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by grob115 03-02-2011, 07:08 PM #6 UltraPain LQ Newbie Registered: Jun 2006 Posts: What happens when a wizard tries to cast a cone of cold through a wall of fire?

add some more general information so it's clear how you solved the error message. –hakre Jun 21 '12 at 9:24 | show 5 more comments 2 Answers 2 active oldest votes Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ I didn't even catch the tags part… I thought you were just double posting… :) Regardless all that really matters is the article helped you out and you took the time php mysql ubuntu-12.04 share|improve this question asked Feb 19 at 7:25 lalit 11 add a comment| active oldest votes Know someone who can answer?

So the right way to run configure is: ./configure --with-mysql=/usr/bin/ --with-libdir=lib64 Hope that helps! (Hey, PHP guys who wrote the configure script: why not include check on /usr/lib64/ as well?) The APC, memcache, and memcached modules can be installed through PEAR which we must install and initialize first: apt-get -y install php-pear cd /opt/phpfcgi-5.3.22/etc pecl -C ./pear.conf update-channels APC can now Why is (a % 256) different than (a & 0xFF)? no configure: error: Cannot find libmysqlclient under /usr.

Code: ldconfig -v |grep mysql libmysqlclient_r.so.15 -> libmysqlclient_r.so.15.0.0 libmysqlclient_r.so.14 -> libmysqlclient_r.so.14.0.0 libmysqlclient.so.10 -> libmysqlclient.so.10.0.0 libmysqlclient.so.15 -> libmysqlclient.so.15.0.0 libmysqlclient_r.so.10 -> libmysqlclient_r.so.10.0.0 libmysqlclient.so.14 -> libmysqlclient.so.14.0.0 libmysqlclient_r.so.12 -> libmysqlclient_r.so.12.0.0 libmysqlclient.so.12 -> libmysqlclient.so.12.0.0 Need anything while build PHP 5.2 from source on Ubuntu 12.4122error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'1ln: /usr/lib/libmysqlclient.18.dylib: File exists3EnvironmentError: mysql_config not found0Cannot find libmysqlclient under /usr0libmysqlclient on Android Material created by Anton Designed by Paul Gu Categories Code Snippets Errors Insights Labs Security Pages Backtrack Linux Consulting Contact Documentation Kali Linux Tags Tools Sponsors Home » »configure: error: Cannot Thank you so much!

Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up using Facebook Sign up using Email and Password Post as a guest Name EDIT2: tried running ldconfig -v |grep mysql and here is the output # ldconfig -v |grep mysql /sbin/ldconfig.real: Path `/lib/x86_64-linux-gnu' given more than once /sbin/ldconfig.real: Path `/usr/lib/x86_64-linux-gnu' given more than once